Back to overview
Resolved

Upper Hutt District Zone 1 is down

Aug 20, 2026 at 11:04am UTC
Affected services
Upper Hutt District Zone 1

Resolved
Aug 20, 2026 at 11:11am UTC

Upper Hutt District Zone 1 recovered.

Created
Aug 20, 2026 at 11:04am UTC

Upper Hutt District Zone 1 is degraded.